API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginTryGetAttribute Method (String, String)

Gets the value of the specified string attribute of the plug-in.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool TryGetAttribute(
	string FieldName,
	ref string FieldValue
)

Parameters

FieldName
Type: SystemString
The name of the attribute to get.
FieldValue
Type: SystemString
The value of the attribute.

Return Value

Type: Boolean
True on success.
See Also