API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginTryGetAttribute Method (String, Int32)

Gets the value of the specified int attribute of the plug-in.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public bool TryGetAttribute(
	string FieldName,
	ref int FieldValue
)

Parameters

FieldName
Type: SystemString
The name of the attribute to get.
FieldValue
Type: SystemInt32
The value of the attribute.

Return Value

Type: Boolean
True on success.
See Also