API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginGetStringAttribute Method

Gets the value of the specified string attribute of the plug-in.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public string GetStringAttribute(
	string FieldName
)

Parameters

FieldName
Type: SystemString
The name of the attribute to get.

Return Value

Type: String
The value of the attribute, or an empty string if the plug-in does not have such an attribute.
Exceptions
ExceptionCondition
CannotGetAttributeForPluginException Thrown when the getting of the attribute failed for an unknown reason (might indicate an invalid plug-in name).
CannotGetAttributeForPluginDueToIncorrectTypeException Thrown when getting a value with an invalid type for the specified field.
CannotGetAttributeForPluginDueToInexistantFieldException Thrown when getting the value of an inexistent field.
See Also