API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PlacingTypesLeaderLinePlacing Method

The object is placed attached to a leader line.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static PlacingBase LeaderLinePlacing(
	Point LeaderLineStartPoint
)

Parameters

LeaderLineStartPoint
Type: Tekla.Structures.Geometry3dPoint
The start point of the leader line.

Return Value

Type: PlacingBase
A new leader line placing instance.
See Also