API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PlacingTypesBaseLinePlacing Method

The object is placed using a line as a reference. This will thus define the object's X-axis along that line.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static PlacingBase BaseLinePlacing(
	Point StartPoint,
	Point EndPoint
)

Parameters

StartPoint
Type: Tekla.Structures.Geometry3dPoint
The first point of the line.
EndPoint
Type: Tekla.Structures.Geometry3dPoint
The second point of the line.

Return Value

Type: PlacingBase
A new base line placing instance.
See Also