API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PlacingDistanceAttributes Class

The PlacingDistanceAttributes class contains the basic attributes for placing distances.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class PlacingDistanceAttributes : GenericAttributesBase, 
	ICloneable

The PlacingDistanceAttributes type exposes the following members.

Constructors
  NameDescription
Public methodPlacingDistanceAttributes
Initializes a new instance of the PlacingDistanceAttributes class. The default values are a 0.0 search margin and a 0.0 minimal distance.
Public methodPlacingDistanceAttributes(Double, Double)
Creates a new placing distance attributes instance with the given search marginal and minimal distance.
Public methodPlacingDistanceAttributes(Double, Double, Double)
Creates a new placing distance attributes instance with the given search margin, minimal and maximal distance.
Top
Properties
  NameDescription
Public propertyMaximalDistance
Gets or sets the maximal distance for placing.
Public propertyMinimalDistance
Gets or sets the minimal distance for placing.
Public propertySearchMargin
Gets or sets the search marginal for placing.
Top
Methods
  NameDescription
Public methodClone
Creates a new object that is a copy of the current instance.
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also