API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PlacingDirectionAttributes Class

The PlacingDirectionAttributes class contains the basic attributes for placing directions.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingGenericAttributesBase
    Tekla.Structures.DrawingPlacingDirectionAttributes

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class PlacingDirectionAttributes : GenericAttributesBase

The PlacingDirectionAttributes type exposes the following members.

Constructors
  NameDescription
Public methodPlacingDirectionAttributes
Creates a new placing direction attributes instance. The positive and negative directions are set to false by default.
Public methodPlacingDirectionAttributes(Boolean, Boolean)
Creates a new placing direction attributes instance.
Top
Properties
  NameDescription
Public propertyNegative
The negative direction of placing.
Public propertyPositive
The positive direction of placing.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also