API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerInputWithinAView Class

The PickerInputWithinAView class is the base class of PickerInput instances that represent a valid pick of point(s) or object(s) in a view.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public abstract class PickerInputWithinAView : PickerInput

The PickerInputWithinAView type exposes the following members.

Properties
  NameDescription
Public propertyPickedView
The view within which the pick occurred.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides PickerInputIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.