![]() | PickerInputTwoPoints Class |
The PickerInputTwoPoints class represents a pick of two points in a view.
Used for values asked by UI.Picker.PickTwoPoints(string FirstPrompt, string SecondPrompt, out Point FirstPickedPoint, out Point SecondPickedPoint, out ViewBase PickedView).

SystemObject
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputPointsWithinAView
Tekla.Structures.DrawingPickerInputTwoPoints
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputPointsWithinAView
Tekla.Structures.DrawingPickerInputTwoPoints
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The PickerInputTwoPoints type exposes the following members.

Name | Description | |
---|---|---|
![]() | PickerInputTwoPoints |
Creates a new PickerInputTwoPoints instance with two points selected in a view.
|

Name | Description | |
---|---|---|
![]() | FirstPickedPoint |
The first picked point in the view coordinates.
|
![]() | PickedView |
The view within which the pick occurred.
(Inherited from PickerInputWithinAView.) |
![]() | SecondPickedPoint |
The second picked point in the view coordinates.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides PickerInputPointsWithinAViewIsEqual(Object).) |