![]() | PickerInputThreePoints Class |
The PickerInputThreePoints class represents a pick of three points in a view.
Used for values asked by UI.Picker.PickThreePoints(string FirstPrompt, string SecondPrompt, string ThirdPrompt, out Point FirstPickedPoint, out Point SecondPickedPoint, out Point ThirdPickedPoint, out ViewBase PickedView).

SystemObject
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputPointsWithinAView
Tekla.Structures.DrawingPickerInputThreePoints
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputPointsWithinAView
Tekla.Structures.DrawingPickerInputThreePoints
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The PickerInputThreePoints type exposes the following members.

Name | Description | |
---|---|---|
![]() | PickerInputThreePoints |
Creates a new PickerInputThreePoints instance with one point selected in a view.
|

Name | Description | |
---|---|---|
![]() | FirstPickedPoint |
The first picked point in the view coordinates.
|
![]() | PickedView |
The view within which the pick occurred.
(Inherited from PickerInputWithinAView.) |
![]() | SecondPickedPoint |
The second picked point in the view coordinates.
|
![]() | ThirdPickedPoint |
The third picked point in the view coordinates.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides PickerInputPointsWithinAViewIsEqual(Object).) |