API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerInputPoint Constructor

Creates a new PickerInputPoint instance with one point selected in a view.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public PickerInputPoint(
	ViewBase pickedView,
	Point pickedPoint
)

Parameters

pickedView
Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.
pickedPoint
Type: Tekla.Structures.Geometry3dPoint
The picked point in the view coordinates.
See Also