API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerInputPoint Class

The PickerInputPoint class represents a pick of one point in a view. Used for values asked by UI.Picker.PickPoint(string Prompt, out Point PickedPoint, out ViewBase PickedView).
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public class PickerInputPoint : PickerInputPointsWithinAView

The PickerInputPoint type exposes the following members.

Constructors
  NameDescription
Public methodPickerInputPoint
Creates a new PickerInputPoint instance with one point selected in a view.
Top
Properties
  NameDescription
Public propertyPickedPoint
The picked point in the view coordinates.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides PickerInputPointsWithinAViewIsEqual(Object).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.