![]() | PickerInputObjectAndAPoint Class |
The PickerInputObjectAndAPoint class represents a pick of an object in a view.
It provides both the picked object and the point used to pick the object.
Used for values asked by UI.Picker.PickObject(string Prompt, out DrawingObject PickedObject, out ViewBase PickedView, out Point PickedPoint).

SystemObject
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputObject
Tekla.Structures.DrawingPickerInputObjectAndAPoint
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputObject
Tekla.Structures.DrawingPickerInputObjectAndAPoint
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The PickerInputObjectAndAPoint type exposes the following members.

Name | Description | |
---|---|---|
![]() | PickerInputObjectAndAPoint |
Creates a new PickerInputObjectAndAPoint instance representing the pick of a drawing object and
the coordinates of the point used to pick the object.
|

Name | Description | |
---|---|---|
![]() | PickedObject |
Gets or sets the picked object in the view.
(Inherited from PickerInputObject.) |
![]() | PickedPoint |
Gets or sets the picked point in the view coordinates.
|
![]() | PickedView |
The view within which the pick occurred.
(Inherited from PickerInputWithinAView.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides PickerInputObjectIsEqual(Object).) |