![]() | PickerInputNPoints Class |
The PickerInputNPoints class represents a pick of several points in a view.
Used for values asked by UI.Picker.PickPoints(StringList Prompts, out PointList PickedPoints, out ViewBase PickedView) and
UI.Picker.PickPoints(int NumberOfPicks, StringList Prompts, out PointList PickedPoints, out ViewBase PickedView).

SystemObject
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputPointsWithinAView
Tekla.Structures.DrawingPickerInputNPoints
Tekla.Structures.DrawingPickerInput
Tekla.Structures.DrawingPickerInputWithinAView
Tekla.Structures.DrawingPickerInputPointsWithinAView
Tekla.Structures.DrawingPickerInputNPoints
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The PickerInputNPoints type exposes the following members.

Name | Description | |
---|---|---|
![]() | PickerInputNPoints |
Creates a new PickerInputNPoints instance representing N points selected in a view.
|

Name | Description | |
---|---|---|
![]() | PickedPoints |
Gets or sets the list of picked points in the view coordinates.
|
![]() | PickedView |
The view within which the pick occurred.
(Inherited from PickerInputWithinAView.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Inherited from PickerInputPointsWithinAView.) |