API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerInputInterrupt Class

The PickerInputInterrupt class represents the interruption of picking by the user (e.g. by pressing Escape while requested to pick points). Used for values asked by any UI.Picker.Pick* method where an interrupt happens by the user.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPickerInput
    Tekla.Structures.DrawingPickerInputInterrupt

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public class PickerInputInterrupt : PickerInput

The PickerInputInterrupt type exposes the following members.

Constructors
  NameDescription
Public methodPickerInputInterrupt
Creates a new PickerInputInterrupt instance representing the interruption of picking by the user.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides PickerInputIsEqual(Object).)
Top
See Also