![]() | OpenGraphicObjectOpenGraphicObjectAttributes Class |
The OpenGraphicObjectAttributes class is the attributes class of the open graphic object.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingOpenGraphicObjectOpenGraphicObjectAttributes
Tekla.Structures.DrawingArcArcAttributes
Tekla.Structures.DrawingLineLineAttributes
Tekla.Structures.DrawingPolylinePolylineAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingOpenGraphicObjectOpenGraphicObjectAttributes
Tekla.Structures.DrawingArcArcAttributes
Tekla.Structures.DrawingLineLineAttributes
Tekla.Structures.DrawingPolylinePolylineAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The OpenGraphicObjectOpenGraphicObjectAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | Arrowhead |
The arrowhead attributes of the open graphic object. The end points of an open graphic object
can contain arrowheads.
|
![]() | Line |
The line attributes of the graphic object. A graphic object always consists of lines.
(Inherited from GraphicObjectGraphicObjectAttributes.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Inherited from AttributesBase.) |
![]() | LoadAttributes |
Loads the attributes from the specified file.
(Inherited from AttributesBase.) |