MultiDrawing Class

The MultiDrawing class is for handling multidrawings.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class MultiDrawing : Drawing

The MultiDrawing type exposes the following members.

Properties
  NameDescription
Public propertyCommitMessage
Gets the commit message
(Inherited from Drawing.)
Public propertyCreationDate
The drawing creation date.
(Inherited from Drawing.)
Public propertyDrawingTypeStr
The type of the drawing
(Inherited from Drawing.)
Public propertyIsFrozen
Describes whether the drawing is frozen.
(Inherited from Drawing.)
Public propertyIsIssued
Describes whether the drawing is issued.
(Inherited from Drawing.)
Public propertyIsIssuedButModified
Describes whether the drawing is issued but modified since it was issued.
(Inherited from Drawing.)
Public propertyIsLocked
Describes whether the drawing is locked.
(Inherited from Drawing.)
Public propertyIsLockedBy
Gets the logged in username that set the drawing to locked
(Inherited from Drawing.)
Public propertyIsMasterDrawing
Describes whether the drawing is a master drawing (shown with a special symbol on the drawing list).
(Inherited from Drawing.)
Public propertyIsReadyForIssue
Describes whether the drawing is ready for issue.
(Inherited from Drawing.)
Public propertyIsReadyForIssueBy
Gets the logged in username that set the drawing Ready for issue
(Inherited from Drawing.)
Public propertyIssuingDate
The drawing issuing date.
(Inherited from Drawing.)
Public propertyLayout
Gets the drawing layout attributes.
(Inherited from Drawing.)
Public propertyMark
The drawing mark.
(Inherited from Drawing.)
Public propertyModificationDate
The drawing modification date.
(Inherited from Drawing.)
Public propertyName
The name of the drawing.
(Inherited from Drawing.)
Public propertyOutputDate
The drawing output date. XS_DISABLE_DRAWING_PLOT_DATE controls whether this date is set.
(Inherited from Drawing.)
Public propertyQueryReturnValue
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.)
Public propertySectionViewStartLabel
Gets the drawing attribute for start label of section view
(Inherited from Drawing.)
Public propertyTitle1
The first drawing title.
(Inherited from Drawing.)
Public propertyTitle2
The second drawing title.
(Inherited from Drawing.)
Public propertyTitle3
The third drawing title.
(Inherited from Drawing.)
Public propertyUpToDateStatus
Gets the drawing up to date status.
(Inherited from Drawing.)
Top
Methods
  NameDescription
Public methodCommitChanges
Commits the changes made to the drawings database so far. Commit inserts a kind of save-point into the database and the save-point will be retrieved if the user does undo. Commit also executes all messages. Please note that you need to also to save the drawings database to persists the changes to disk.
(Inherited from Drawing.)
Public methodCommitChanges(String)
Commits the changes made to the drawings database so far. Commit inserts a kind of save-point into the database and the save-point will be retrieved if the user does undo. Commit also executes all messages. Please note that you need to also to save the drawings database to persists the changes to disk.
(Inherited from Drawing.)
Public methodDelete
Deletes the drawing. An active drawing cannot be deleted.
(Inherited from Drawing.)
Public methodGetDoubleUserProperties(DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetDoubleUserProperties(ListString, DictionaryString, Double)
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetIntegerUserProperties(ListString, DictionaryString, Int32)
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetPlotFileName
Get plot file name.
(Inherited from Drawing.)
Public methodGetPlotFileNameExt
Get plot file name.
(Inherited from Drawing.)
Public methodGetSheet
Gets the sheet of the drawing.
(Inherited from Drawing.)
Public methodGetStringUserProperties(DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetStringUserProperties(ListString, DictionaryString, String)
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Double)
Gets a double property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, Int32)
Gets an integer property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodGetUserProperty(String, String)
Gets a string property from the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodInsert
Not supported.
(Overrides DatabaseObjectInsert.)
Public methodIsSameDatabaseObject
Returns true if the current object and the given object are referencing the same database object.
(Inherited from Drawing.)
Public methodModify
Applies the changes made to the drawing attributes.
(Overrides DatabaseObjectModify.)
Public methodPlaceViews
Places views on the sheet. Computes the required size of the views to fit the parts, then places the views so that they fit on the sheet and do not overlap. Adjusts the sheet size if needed.
(Inherited from Drawing.)
Public methodSelect
Selects the drawing.
(Overrides DatabaseObjectSelect.)
Public methodSetUserProperty(String, Double)
Sets a double property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the drawing object. The object has to be in a drawing before the method can be used.
(Inherited from DatabaseObject.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next