![]() | ModelObjectHatchAttributes Class |
The ModelObjectHatchAttributes class contains hatch attributes for model object hatches.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingHatchAttributes
Tekla.Structures.DrawingModelObjectHatchAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingHatchAttributes
Tekla.Structures.DrawingModelObjectHatchAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The ModelObjectHatchAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | Angle |
The angle in which to draw the hatch.
(Inherited from HatchAttributes.) |
![]() | AutomaticScaling | |
![]() | BackgroundColor |
The background color of the hatch.
(Inherited from HatchAttributes.) |
![]() | Color |
The color of the hatch.
(Inherited from HatchAttributes.) |
![]() | DrawBackgroundColor |
Sets whether the background color will be enabled or disabled for the hatch.
See also: BackgroundColor.
(Inherited from HatchAttributes.) |
![]() | FactorType |
The type of the hatch factor.
(Inherited from HatchAttributes.) |
![]() | Name |
The name of the hatch.
If an empty string is given as hatch name it will become "None".
(Inherited from HatchAttributes.) |
![]() | ScaleX |
The scale value of the hatch in the X-direction.
(Inherited from HatchAttributes.) |
![]() | ScaleY |
The scale value of the hatch in the Y-direction.
(Inherited from HatchAttributes.) |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |