![]() | ModelObjectHatchAttributes Class |
The ModelObjectHatchAttributes class contains hatch attributes for model object hatches.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingHatchAttributes
Tekla.Structures.DrawingModelObjectHatchAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingHatchAttributes
Tekla.Structures.DrawingModelObjectHatchAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The ModelObjectHatchAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | AutomaticScaling | |

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |