MarkBaseMarkBaseAttributes Class

The MarkBaseAttributes class is the attributes class for the mark base.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public abstract class MarkBaseAttributes : AttributesBase, 
	IPreferredPlacing

The MarkBaseMarkBaseAttributes type exposes the following members.

Constructors
  NameDescription
Public methodMarkBaseMarkBaseAttributes
Creates a new default mark base attributes instance that loads standard attributes.
Public methodMarkBaseMarkBaseAttributes(String)
Creates a new mark base attributes instance with the given attributes file's filename.
Top
Properties
  NameDescription
Public propertyAngle
The actual angle of the mark, in degrees. Can differ from the rotation angle set by the user for marks, e.g. 45-degree column marks in GA drawings or when placing mark along part edges.
Public propertyArrowHead
The arrowhead of the leader line(s).
Public propertyCustomPresentation
Custom presentation GUID to be applied to the object type
Public propertyFrame
The frame attributes of the mark's labels.
Public propertyPlacingAttributes
The placing attributes that the object should use. Using these you can specify whether the object is automatically arranged in the drawing or not.
Public propertyPreferredPlacing
The type of placing the object should use. See the preferred placing types for different types of placing.
Public propertyRotationAngle
The mark rotation angle set by the user. Unit is degrees.
Public propertyTextAlignment
The mark text alignment.
Public propertyTransparentBackground
The mark text background transparency. (transparent/opaque)
Top
Methods
  NameDescription
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next