![]() | MarkBase Class |
The MarkBase class contains general mark information and can be
selected and modified with the general attributes.

SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingMarkBase
Tekla.Structures.DrawingMark
Tekla.Structures.DrawingMarkSet
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingMarkBase
Tekla.Structures.DrawingMark
Tekla.Structures.DrawingMarkSet
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The MarkBase type exposes the following members.

Name | Description | |
---|---|---|
![]() | Attributes |
Gets or sets the mark base attributes.
|
![]() | Hideable |
Accesses the information if this object is hidden or not or if it should be.
|
![]() | InsertionPoint |
The insertion point of the mark.
|
![]() | IsAssociativeNote |
Gets a value indicating whether the mark is an associative note.
|
![]() | Placing |
The current placing of the object.
See the placing types for different placing options.
|
![]() | QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) |

Name | Description | |
---|---|---|
![]() | Delete |
Deletes the instance from the database.
(Inherited from DatabaseObject.) |
![]() | GetAxisAlignedBoundingBox |
Returns the axis aligned bounding box of the text (rectangle format).
|
![]() | GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) |
![]() | GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetObjectAlignedBoundingBox |
Returns the object aligned bounding box of the text (rectangle format).
|
![]() | GetObjects |
Gets the children objects of the current object.
|
![]() | GetObjects(Type) |
Gets the children objects of the current object that are of certain types.
|
![]() | GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) |
![]() | GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) |
![]() | GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) |
![]() | Insert |
Inserts the object instance into the database. The inserted instance must be of a real type.
(Inherited from DatabaseObject.) |
![]() | IsEqual |
Compares the current object with the given object.
Checks every field of both objects for equality.
(Inherited from DrawingObject.) |
![]() | IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) |
![]() | Modify |
Modifies the instance in the database.
(Inherited from DatabaseObject.) |
![]() | MoveObjectRelative |
Moves the object using the move vector.
|
![]() | Select |
Selects the object instance from the database.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |

The following example enumerates through all marks in all views and changes
their frame types to sharpened and their frame colors to red.
using Tekla.Structures.Drawing; public class Example { public void Example1() { DrawingHandler MyDrawingHandler = new DrawingHandler(); if(MyDrawingHandler.GetConnectionStatus()) { MarkBase MyMarkBase; DrawingObjectEnumerator views = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews(); while(views.MoveNext()) { DrawingObjectEnumerator allObjects = (views.Current as ViewBase).GetAllObjects(); while(allObjects.MoveNext()) { if(allObjects.Current is MarkBase) { MyMarkBase = allObjects.Current as MarkBase; MyMarkBase.Attributes.Frame.Color = DrawingColors.Red; MyMarkBase.Attributes.Frame.Type = FrameTypes.Sharpened; MyMarkBase.Modify(); } } } } } }