API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MarkMarkAttributes Constructor (ModelObject, String)

Creates a new mark attributes instance that loads the specified attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public MarkAttributes(
	ModelObject modelObject,
	string AttributesFile
)

Parameters

modelObject
Type: Tekla.Structures.DrawingModelObject
The ModelObject defining the content to load.
AttributesFile
Type: SystemString
The attributes file's filename.
See Also