API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LinkBaseGetObjectAlignedBoundingBox Method

Gets the bounding box for the current object in its local coordinate system.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public RectangleBoundingBox GetObjectAlignedBoundingBox()

Return Value

Type: RectangleBoundingBox
A rectangle bounding box for the current object.

Implements

IObjectAlignedBoundingBoxGetObjectAlignedBoundingBox
See Also