API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LineTypes  Conversion (LineTypes to Int32)

Returns the corresponding int value of the given LineTypes value.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public static explicit operator int (
	LineTypes lineType
)

Parameters

lineType
Type: Tekla.Structures.DrawingLineTypes
The given LineTypes value.

Return Value

Type: Int32
An int value corresponding to the given LineTypes value.
See Also