API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LineTypeAttributes Constructor (LineTypes, DrawingColors)

Creates a new line type attributes instance with the given line type and color.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public LineTypeAttributes(
	LineTypes lineType,
	DrawingColors color
)

Parameters

lineType
Type: Tekla.Structures.DrawingLineTypes
The line type to be used.
color
Type: Tekla.Structures.DrawingDrawingColors
The color to be used.
See Also