API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LineTypeAttributes Class

The LineTypeAttributes class contains basic attributes for lines.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class LineTypeAttributes : GenericAttributesBase

The LineTypeAttributes type exposes the following members.

Constructors
  NameDescription
Public methodLineTypeAttributes
Creates a new line type attributes instance.
Public methodLineTypeAttributes(LineTypes, DrawingColors)
Creates a new line type attributes instance with the given line type and color.
Top
Properties
  NameDescription
Public propertyColor
The color of the line (see DrawingColors for options).
Public propertyType
The type of the line (see LineTypes for options).
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also