API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Line Constructor (ViewBase, Point, Point, Double)

Creates a new line instance with two points and a bulge using standard attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public Line(
	ViewBase view,
	Point startPoint,
	Point endPoint,
	double bulge
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
startPoint
Type: Tekla.Structures.Geometry3dPoint
The start point to be used.
endPoint
Type: Tekla.Structures.Geometry3dPoint
The end point to be used.
bulge
Type: SystemDouble
The bulge to be used.
See Also