API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LeaderLinePlacing Class

The LeaderLinePlacing class defines a placing where the object is placed attached to a leader line.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class LeaderLinePlacing : PlacingBase

The LeaderLinePlacing type exposes the following members.

Constructors
  NameDescription
Public methodLeaderLinePlacing
Creates a new leader line placing instance. The given point defines the start point of the leader line.
Top
Properties
  NameDescription
Public propertyStartPoint
The start point of the leader line (if multiple leader lines exist, only returns the first).
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides PlacingBaseIsEqual(Object).)
Top
See Also