API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LeaderLineAndParentObjectAlongPartPlacingType Class

The LeaderLineAndParentObjectAlongPartPlacingType class defines a placing type that places the object with a leader line and rotated to be at the same angle as the connected part.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPreferredPlacingTypeBase
    Tekla.Structures.DrawingLeaderLineAndParentObjectAlongPartPlacingType

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class LeaderLineAndParentObjectAlongPartPlacingType : PreferredPlacingTypeBase

The LeaderLineAndParentObjectAlongPartPlacingType type exposes the following members.

Constructors
  NameDescription
Public methodLeaderLineAndParentObjectAlongPartPlacingType
Creates a new leader line and parent object along part placing type instance.
Top
See Also