API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LayoutAttributes Constructor (String, Drawing)

Creates a new layout attributes instance that loads drawing layout attributes from the specified attribute file.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public LayoutAttributes(
	string AttributeFile,
	Drawing Drawing
)

Parameters

AttributeFile
Type: SystemString
The name of the drawing attribute file. E.g. "standard".
Drawing
Type: Tekla.Structures.DrawingDrawing
The type of drawing to load layout attributes for.
See Also