![]() | LayoutAttributes Class |
The LayoutAttributes class contains attributes for controlling the drawing layout.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The LayoutAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | LayoutAttributes | Obsolete.
Creates a new layout attributes instance that loads standard attributes.
|
![]() | LayoutAttributes(String) | Obsolete.
Creates a new layout attributes instance that loads drawing layout attributes from the specified attribute file.
|
![]() | LayoutAttributes(Drawing) |
Creates a new layout attributes instance that loads standard attributes.
|
![]() | LayoutAttributes(String, Drawing) |
Creates a new layout attributes instance that loads drawing layout attributes from the specified attribute file.
|

Name | Description | |
---|---|---|
![]() | AutoSizeOptions |
Gets or sets the auto size options that control the drawing sheet
size. Setting this property will change the SizeDefinitionMode to AutoSize.
|
![]() | ListHiddenObjectsInTemplates |
Gets or sets the property for controlling whether to list hidden objects in templates.
|
![]() | SheetSize |
Gets or sets the sheet size. Setting this property will change the
SizeDefinitionMode to SpecifiedSize.
|
![]() | SizeDefinitionMode |
Gets or sets the size definition mode.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads drawing layout attributes from the specified attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |