API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

InvalidTypeException Class

The InvalidTypeException class defines the exception that is thrown when a type was not one of the allowed ones.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class InvalidTypeException : TeklaStructuresDrawingsApplicationException

The InvalidTypeException type exposes the following members.

Constructors
  NameDescription
Public methodInvalidTypeException
Creates a new InvalidTypeException instance.
Top
See Also