API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

InsidePartAlongPartPlacingType Class

The InsidePartAlongPartPlacingType class defines a placing type that places the object using the base line placing. The base line used is in the middle of the part, aligned with the part.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPreferredPlacingTypeBase
    Tekla.Structures.DrawingInsidePartAlongPartPlacingType

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class InsidePartAlongPartPlacingType : PreferredPlacingTypeBase

The InsidePartAlongPartPlacingType type exposes the following members.

Constructors
  NameDescription
Public methodInsidePartAlongPartPlacingType
Creates a new inside part along part placing type instance.
Top
See Also