API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IMovableRelativeMoveObjectRelative Method

Moves the current object using the move vector. The move vector can be calculated as in the following example.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
bool MoveObjectRelative(
	Vector MoveVector
)

Parameters

MoveVector
Type: Tekla.Structures.Geometry3dVector
The move vector to be used for moving the object.

Return Value

Type: Boolean
True on success.
Examples
The example calculates a move vector from two points. The move vector in the example will move an object 1000 points in the +X direction.
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Tekla.Structures.Geometry3d.Vector MoveVec =
               new Tekla.Structures.Geometry3d.Vector(new Point(1000, 0) - new Point(0, 0));
       }
}
See Also