API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Image Constructor (ViewBase, Point, Size, String, EmbeddedObjectAttributes)

Initializes a new instance of the Image class using the specified attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public Image(
	ViewBase view,
	Point insertionPoint,
	Size frameSize,
	string fileName,
	EmbeddedObjectAttributes attributes
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
insertionPoint
Type: Tekla.Structures.Geometry3dPoint
The insertion point to be used.
frameSize
Type: Tekla.Structures.DrawingSize
The frames size.
fileName
Type: SystemString
The filename to be used.
attributes
Type: Tekla.Structures.DrawingEmbeddedObjectAttributes
The attributes to be used.
Exceptions
ExceptionCondition
FileNotFoundExceptionThrown if the specified file does not exist.
See Also