![]() | Hideable Class |
Accesses the information if this object is hidden or not or if it should be.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The Hideable type exposes the following members.



Name | Description | |
---|---|---|
![]() | HideFromDrawing |
Hides this object from the whole drawing.
Calling Modify on the object is required to hide the object.
|
![]() | HideFromDrawingView |
Hides this object from the drawing view.
Calling Modify on the object is required to hide the object.
|
![]() | ShowInDrawing |
Shows this object in the whole drawing.
Calling Modify on the object is required to show the object.
|
![]() | ShowInDrawingView |
Shows this object in the drawing view.
Calling Modify on the object is required to show the object.
|

This example opens the first available drawing and hides all ModelObject's from the view.
namespace Hideable { using Tekla.Structures.Drawing; public static class Example { public static void Example1() { DrawingHandler drawingHandler = new DrawingHandler(); DrawingEnumerator drawingList = drawingHandler.GetDrawings(); if(drawingList.MoveNext()) { Drawing currentDrawing = drawingList.Current; drawingHandler.SetActiveDrawing(currentDrawing); DrawingObjectEnumerator objectList = currentDrawing.GetSheet().GetAllObjects(typeof(ModelObject)); while(objectList.MoveNext()) { ModelObject currentObject = objectList.Current as ModelObject; if(currentObject != null) { if(!currentObject.Hideable.IsHidden) // The object is not yet hidden { currentObject.Hideable.HideFromDrawingView(); currentObject.Modify(); } } } } } } }