![]() | GridGridAttributes Class |
The GridAttributes class is the attributes class for the grid.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The GridGridAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | GridGridAttributes |
Creates a new default grid attributes instance that loads standard attributes.
|
![]() | GridGridAttributes(String) |
Creates a new grid attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | DrawOnlyTextLabelsNotGrids |
Set as true if you don't want to draw the grids, only show the grids' text labels.
|
![]() | DrawTextAtBottomOfGrid |
Set as true if you want to show the grid's text labels at the bottom of the grid.
|
![]() | DrawTextAtLeftOfGrid |
Set as true if you want to show the grid's text labels at the left of the grid.
|
![]() | DrawTextAtRightOfGrid |
Set as true if you want to show the grid's text labels at the right of the grid.
|
![]() | DrawTextAtTopOfGrid |
Set as true if you want to show the grid's text labels at the top of the grid.
|
![]() | Font |
The grid's font attributes.
|
![]() | Frame |
The frame attributes of the grid's labels.
|
![]() | Line |
The grid's line attributes.
|
![]() | OffsetAtEndOfLine |
The offset for the end of the grid lines.
|
![]() | OffsetAtStartOfLine |
The offset for the beginning of the grid lines.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |