![]() | GraphicObjectGraphicObjectAttributes Class |
The GraphicObjectAttributes class is the attributes class of the graphic object.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingOpenGraphicObjectOpenGraphicObjectAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingClosedGraphicObjectClosedGraphicObjectAttributes
Tekla.Structures.DrawingOpenGraphicObjectOpenGraphicObjectAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The GraphicObjectGraphicObjectAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | GraphicObjectGraphicObjectAttributes |
Creates a new graphic object attributes instance.
|
![]() | GraphicObjectGraphicObjectAttributes(String) |
Creates a new graphic object attributes instance using the given attribute file's filename.
|

Name | Description | |
---|---|---|
![]() | Line |
The line attributes of the graphic object. A graphic object always consists of lines.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Inherited from AttributesBase.) |
![]() | LoadAttributes |
Loads the attributes from the specified file.
(Inherited from AttributesBase.) |