API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Frame Constructor

Creates a new frame instance with the specified frame type and color.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public Frame(
	FrameTypes FrameType,
	DrawingColors FrameColor
)

Parameters

FrameType
Type: Tekla.Structures.DrawingFrameTypes
The frame type to be used.
FrameColor
Type: Tekla.Structures.DrawingDrawingColors
The frame color to be used.
See Also