![]() | Frame Class |
The Frame class defines a frame that can be given to objects, including texts.
A frame is a box around the object. You can specify the color and shape of the box.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The Frame type exposes the following members.



Name | Description | |
---|---|---|
![]() | Clone |
Clones the object.
|
![]() | GetAxisAlignedBoundingBox |
Returns the bounding box of the frame in the global axis coordinate system.
|
![]() | GetObjectAlignedBoundingBox |
Returns the bounding box of the frame in the local coordinate system.
|
![]() | IsEqual |
Compares the current object with an object of the same type.
|