API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

FontAttributes Constructor (DrawingColors, Double, String, Boolean, Boolean)

Creates a new font attributes instance with the given parameters.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public FontAttributes(
	DrawingColors color,
	double height,
	string fontName,
	bool italic,
	bool bold
)

Parameters

color
Type: Tekla.Structures.DrawingDrawingColors
The color of the font.
height
Type: SystemDouble
The height of the font.
fontName
Type: SystemString
The name of the font.
italic
Type: SystemBoolean
The italic specifier.
bold
Type: SystemBoolean
The bold specifier.
See Also