API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

FontAttributes Class

The FontAttributes class contains the basic attributes for fonts.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class FontAttributes : GenericAttributesBase, 
	ICloneable

The FontAttributes type exposes the following members.

Constructors
  NameDescription
Public methodFontAttributes
Creates a new font attributes instance. The default color is black, the height is 2.5, the font name is Arial and the values of italic and bold are false.
Public methodFontAttributes(DrawingColors, Double, String, Boolean, Boolean)
Creates a new font attributes instance with the given parameters.
Top
Properties
  NameDescription
Public propertyBold
Whether the font is bold.
Public propertyColor
The color of the font.
Public propertyHeight
The height of the font (in millimeters).
Public propertyItalic
Whether the font is italic.
Public propertyName
The name of the font.
Top
Methods
  NameDescription
Public methodClone
Creates a new object that is a copy of the current instance.
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).)
Top
See Also