API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

EmbeddedObjectFrameGetAxisAlignedBoundingBox Method

Returns the bounding box of the frame in the global axis coordinate system.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public RectangleBoundingBox GetAxisAlignedBoundingBox()

Return Value

Type: RectangleBoundingBox
The bounding box of the frame in the global axis coordinate system.

Implements

IAxisAlignedBoundingBoxGetAxisAlignedBoundingBox
See Also