![]() | EmbeddedObjectFrame Class |
The EmbeddedObjectFrame class defines the frame object for embedded objects.

Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The EmbeddedObjectFrame type exposes the following members.

Name | Description | |
---|---|---|
![]() | EmbeddedObjectFrame |
Creates a new embedded object frame instance with the specified line type and color.
|

Name | Description | |
---|---|---|
![]() | Color | Obsolete. |
![]() | Line |
Gets or sets the line type of the frame.
|
![]() | LineType | Obsolete. |
![]() | Type |
Gets the frame type (rectangular).
|

Name | Description | |
---|---|---|
![]() | GetAxisAlignedBoundingBox |
Returns the bounding box of the frame in the global axis coordinate system.
|
![]() | GetObjectAlignedBoundingBox |
Returns the bounding box of the frame in the local coordinate system.
|
![]() | IsEqual |
Compares the current object with an object of the same type.
|