API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ElementBaseIsEqual Method

Compares the current object with the given object. Checks every field of both objects for equality.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public abstract bool IsEqual(
	Object ObjectToCompare
)

Parameters

ObjectToCompare
Type: SystemObject
An object of the same type to be used for comparing.

Return Value

Type: Boolean
True if the field values of both objects match.

Implements

IIsEqualIsEqual(Object)
See Also