API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DwgObject Constructor (ViewBase, Point, String)

Creates a new DwgObject instance with the given parameters.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public DwgObject(
	ViewBase view,
	Point insertionPoint,
	string fileName
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
insertionPoint
Type: Tekla.Structures.Geometry3dPoint
The insertion point to be used.
fileName
Type: SystemString
The filename to be used.
Exceptions
ExceptionCondition
FileNotFoundExceptionThrown if the specified file does not exist.
See Also