![]() | DrawingObjectEnumerator Class |
The DrawingObjectEnumerator class provides the means to iterate through drawing object instances. Drawing object enumerators
are generated by the container view and they contain drawing objects that are children of the container view instance.

SystemObject
Tekla.Structures.DrawingDrawingEnumeratorBase
Tekla.Structures.DrawingDrawingObjectEnumerator
Tekla.Structures.DrawingDrawingEnumeratorBase
Tekla.Structures.DrawingDrawingObjectEnumerator
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The DrawingObjectEnumerator type exposes the following members.


Name | Description | |
---|---|---|

Name | Description | |
---|---|---|

using Tekla.Structures.Drawing; public class Example { public void Example1() { DrawingHandler DrawingHandler = new DrawingHandler(); Drawing CurrentDrawing = DrawingHandler.GetActiveDrawing(); // Loop through all objects in the drawing and delete all existing line objects. DrawingObjectEnumerator AllObjects = CurrentDrawing.GetSheet().GetAllObjects(); while(AllObjects.MoveNext()) { if(AllObjects.Current is Line) { AllObjects.Current.Delete(); } } } }