![]() | DrawingObjectEnumerator Class |
The DrawingObjectEnumerator class provides the means to iterate through drawing object instances. Drawing object enumerators
are generated by the container view and they contain drawing objects that are children of the container view instance.

SystemObject
Tekla.Structures.DrawingDrawingEnumeratorBase
Tekla.Structures.DrawingDrawingObjectEnumerator
Tekla.Structures.DrawingDrawingEnumeratorBase
Tekla.Structures.DrawingDrawingObjectEnumerator
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The DrawingObjectEnumerator type exposes the following members.


Name | Description | |
---|---|---|
![]() | GetEnumerator |
Allows the usage of the foreach statement with DrawingObjectEnumerator.
(Inherited from DrawingEnumeratorBase.) |
![]() | GetSize |
Returns the total amout of items.
(Inherited from DrawingEnumeratorBase.) |
![]() | MoveNext |
Moves to the next item in the enumerator.
(Inherited from DrawingEnumeratorBase.) |
![]() | Reset |
Resets the enumerator to the beginning.
(Inherited from DrawingEnumeratorBase.) |

Name | Description | |
---|---|---|
![]() | SelectInstances |
Indicates that the instance Select() is called when the 'Current' item is asked from the enumerator.
The user can set this to 'false' if no members are ever asked from the instance. This is the case
when, for example, asking only a report property from the identifier. Warning: normally the user should not
change this value.
(Inherited from DrawingEnumeratorBase.) |

using Tekla.Structures.Drawing; public class Example { public void Example1() { DrawingHandler DrawingHandler = new DrawingHandler(); Drawing CurrentDrawing = DrawingHandler.GetActiveDrawing(); // Loop through all objects in the drawing and delete all existing line objects. DrawingObjectEnumerator AllObjects = CurrentDrawing.GetSheet().GetAllObjects(); while(AllObjects.MoveNext()) { if(AllObjects.Current is Line) { AllObjects.Current.Delete(); } } } }