![]() | DrawingObjectNoAttributes Class |
The NoAttributes class defines attributes for objects that do not contain any attributes.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDrawingObjectNoAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDrawingObjectNoAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The DrawingObjectNoAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | DrawingObjectNoAttributes |
Creates a new default no attributes instance.
|
![]() | DrawingObjectNoAttributes(String) |
Creates a new no attributes instance. No attributes are loaded from the
attribute file as it is not possible to load attributes for objects of
this type.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
It is not possible to load attributes for objects of this type because
the objects have no attributes.
(Overrides AttributesBaseLoadAttributes(String).) |