API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingObjectGetRelatedObjects Method (Type)

Gets the related objects of the current object that are of certain types.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public DrawingObjectEnumerator GetRelatedObjects(
	Type[] typeFilter
)

Parameters

typeFilter
Type: SystemType
The types of the objects to get.

Return Value

Type: DrawingObjectEnumerator
The related objects of the current object that are of certain types.

Implements

IRelatedObjectsGetRelatedObjects(Type)
See Also