API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingLink Constructor (ViewBase, Point, Drawing, String)

Creates a new drawing link instance using standard attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public DrawingLink(
	ViewBase View,
	Point InsertionPoint,
	Drawing Target,
	string Text
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
A drawing view.
InsertionPoint
Type: Tekla.Structures.Geometry3dPoint
The location for the link.
Target
Type: Tekla.Structures.DrawingDrawing
The link target.
Text
Type: SystemString
The link text visible to the user.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.