API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingHandlerMessageExecutionModeEnum Enumeration

The message execution modes of Tekla Structures.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public enum MessageExecutionModeEnum
Members
  Member nameValueDescription
INSTANT0 Executes messages after each database operation. All objects appear instantly on the screen when using the INSTANT mode.
BY_COMMIT1 Executes messages only when Drawing.CommitChanges() is called.
Remarks

The message execution mode of Tekla Structures controls whether messages are executed after each database operation or by an explicit call to execute messages.

There may be some speed benefits if the BY_COMMIT mode is used when inserting a lot of objects. The messages are then executed once after the objects have been inserted.

See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.